Protect Risk Score

Incident Report for smartnumbers

Resolved

All call traffic is healthy and we can confirm that the rise in default risk scores has ceased. Protect is fully operational.
Posted Oct 21, 2025 - 19:51 UTC

Monitoring

We can confirm that call delivery for BTGSIP customers is stable through Smartnumbers, and risk scoring is operational. We are continuing to monitor call health and working with AWS to understand the root cause.
Posted Oct 21, 2025 - 10:20 UTC

Update

Following the AWS outage at their US-EAST-1 region, AWS have confirmed that there was packetloss within the AWS backbone network at a global level. Smartnumbers are working with AWS Support to investigate this issue.
Posted Oct 20, 2025 - 16:05 UTC

Investigating

We are currently investigating an issue where a number of calls receive a default risk score. Additionally, we are working with 3rd parties to investigate reported faults with BTGSIP integrations.
Posted Oct 20, 2025 - 11:12 UTC
This incident affected: Smartnumbers Protect.