Issue with accessing smartnumbers hub

Incident Report for smartnumbers

Resolved

We identified an issue preventing users logging in to smartnumbers hub and proactively worked with our authentication service provider to resolve the problem within one hour.
Posted Jun 28, 2019 - 12:00 UTC